Lettermint

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Email sending API degraded
Resolved·Partial outage

This incident is resolved. Our email sending API is fully operational and we are no longer seeing any errors or alerts.

Fri, Mar 27, 2026, 06:53 PM
(2 months ago)
·
Affected components
Mar 27, 2026, 06:17 PM
06:30 PM
Updates

Resolved

This incident is resolved. Our email sending API is fully operational and we are no longer seeing any errors or alerts.

Fri, Mar 27, 2026, 06:53 PM

Monitoring

We have deployed a fix for the issues with our email sending API. We are no longer seeing errors and will continue to monitor.

Fri, Mar 27, 2026, 06:32 PM(20 minutes earlier)

Identified

We have identified the issue with our email sending API and are working on a fix. SMTP is not affected. We will provide updates as soon as we have more information.

Fri, Mar 27, 2026, 06:24 PM