Resolved
We have not seen any regressions related to emails being queued for longer than expected. Therefore we're marking this incident as resolved.
If you still notice any issues, do reach out to support.
Monitoring
A fix has been implemented and we're monitoring the situation. Queues are being processed quickly again and the time-to-inbox dropped to sub-10 seconds as expected.
Apologies for the inconvenience this caused.
Identified
We have identified the issue causing a delay in processing of emails and are working on a fix. Currently emails are in queue for an average of ~22 seconds, higher than the usual average of a couple milliseconds.
We will keep you posted once a fix has been implemented.
Investigating
We are currently investigating a sudden increase in queue times for emails. Emails are delayed for ~2 minutes on average.
We will keep you posted.