Write-up published
Resolved
We have continued monitoring and have not observed any further recurrence of this issue.
The incident is now resolved. We have completed a post-mortem and will publish it shortly with more detail on the impact, root cause, and follow-up actions.
Monitoring
We are seeing improvements and services are back to normal. In the meantime, we will keep monitoring the situation closely and apologies for the inconvenience this has caused.
A public post-mortem will also be shared.
Monitoring
A fix is being deployed and we'll be monitoring the situation.
Identified
We have identified the issue and our team is working on a fix. We'll keep you posted.
Apologies for the inconvenience.
Investigating
We are currently investigating reports of email submitted via the SMTP relay not being processed.