We are not seeing any more deferrals with Outlook OLC and mark this incident as resolved.
During the incident we have adjusted our traffic shaping to improve mitigation for incidents like this in the future. We have since seen improvements.
Our sincere apologies for the inconvenience and the delay in delivery of emails sent to consumer Outlook addresses.
Resolved
We are not seeing any more deferrals with Outlook OLC and mark this incident as resolved.
During the incident we have adjusted our traffic shaping to improve mitigation for incidents like this in the future. We have since seen improvements.
Our sincere apologies for the inconvenience and the delay in delivery of emails sent to consumer Outlook addresses.
Monitoring
We are seeing improvements and emails are being delivered.
We will keep monitoring the situation closely.
Identified
We are still actively remediating the issue and have changed our mitigation. You might see deferrals in your webhooks or UI instead of delayed processing. Please note emails are still being retried.
To make sure emails will be delivered, we have increased our maximum wait time to 24 hours instead of 12 hours and are actively monitoring the situation in case further extension is needed. We hope to hear back from Microsoft's Sender Support as soon as possible.
This issue does not impact Microsoft 365 (Outlook 365) addresses nor other providers.
Broadcast is also not affected by the issue.
Our sincere apologies for the inconvenience.
Identified
We are still actively remediating the issue and have changed our mitigation. You might see deferrals in your webhooks or UI instead of delayed processing. Please note emails are still being retried.
To make sure emails will be delivered, we have increased our maximum wait time to 24 hours instead of 12 hours and are actively monitoring the situation in case further extension is needed. We hope to hear back from Microsoft's Sender Support as soon as possible.
This issue does not impact Microsoft 365 (Outlook 365) addresses nor other providers.
Broadcast is also not affected by the issue.
Our sincere apologies for the inconvenience.
Identified
We are still actively remediating the issue.
Our automated traffic shaping has partially mitigated the issue but are awaiting further mitigation from Microsoft. Emails to Outlook OLC are still delayed and might show as Processed for an extended period of time in the UI.
This issue does not impact Microsoft 365 (Outlook 365) addresses nor other providers.
Broadcast is also not affected by the issue.
Our sincere apologies for the inconvenience.
Identified
We are still actively remediating the issue.
Our automated traffic shaping has partially mitigated the issue but are awaiting further mitigation from Microsoft. Emails to Outlook OLC are still delayed and might show as Processed for an extended period of time in the UI.
This issue does not impact Microsoft 365 (Outlook 365) addresses nor other providers.
Identified
Our automated traffic shaping has partially mitigated the issue but are awaiting further mitigation from Microsoft. Emails to Outltook OLC are still delayed and might show as Processed for an extended period of time in the UI.
This issue does not impact Microsoft 365 (Outlook 365) addresses nor other providers.
Identified
We have identified an issue with messages being rate limited against Outlook OLC and are actively remediating. Emails will be delivered after retries and does not impact other providers nor Microsoft 365 (Office 365) tenants.