We’ve been in contact with Spamhaus and the delisting process has now been successfully applied. The delisting has been put into effect, but mail providers that rely on Spamhaus may take some time to refresh and propagate these changes within their own systems and internal caches.
We are currently monitoring the situation closely while these updates continue to propagate. Once we determine that delivery has stabilized and it is safe to proceed, we will begin retrying affected emails that were not yet successfully delivered and provide further updates as needed.
No components marked as affected
Monitoring
We’ve been in contact with Spamhaus and the delisting process has now been successfully applied. The delisting has been put into effect, but mail providers that rely on Spamhaus may take some time to refresh and propagate these changes within their own systems and internal caches.
We are currently monitoring the situation closely while these updates continue to propagate. Once we determine that delivery has stabilized and it is safe to proceed, we will begin retrying affected emails that were not yet successfully delivered and provide further updates as needed.
Identified
We are still actively working on this issue and are awaiting an update from Spamhaus.
We will keep monitoring the situation.
Our sincere apologies for the inconvenience.
Identified
We are still actively working on this issue and are awaiting an update from Spamhaus.
We will keep monitoring the situation.
Our sincere apologies for the inconvenience.
Identified
We are still actively working on this issue. An update from Spamhaus was received ~20 minutes ago and delisting is being propagated worldwide.
We will keep monitoring the situation.
Our sincere apologies for the inconvenience.
Identified
We’ve identified that three of our outbound transactional IP addresses have been blocklisted, affecting email delivery for some customers. The team is currently investigating the cause and working on delisting the IP. In the meantime, the IP address has been suspended and will not be used until the issue is resolved. This does not affect other IPs in the pool nor broadcast routes.
If you have seen a hard bounce because of this, you can safely reactivate the recipient from your suppression management.