Resolved
This incident has been resolved. We applied a fix and have confirmed that the dashboard and Team API are working normally, with no further errors.
Monitoring
We are no longer seeing elevated error rates on the Team API or dashboard and functionality appears to have returned to normal.
We are continuing to monitor the situation closely to ensure stability, but no new errors have been observed since mitigation was applied.
Investigating
We are seeing increased error rates on the Lettermint dashboard and our Team API. Requests to the Team API and actions in the dashboard may fail or respond slowly while we look into this.
Email delivery is not affected. Transactional and broadcast messages are still being sent and processed as normal.
Our team is investigating the cause and we will post an update shortly.