API availability has been fully restored and the platform has remained stable. We reverted a health-check configuration that reacted too aggressively to a brief traffic spike, causing healthy instances to be temporarily removed from service. We have confirmed normal operation and are reviewing additional safeguards to prevent a recurrence.
Resolved
API availability has been fully restored and the platform has remained stable. We reverted a health-check configuration that reacted too aggressively to a brief traffic spike, causing healthy instances to be temporarily removed from service. We have confirmed normal operation and are reviewing additional safeguards to prevent a recurrence.
Monitoring
We experienced a brief period of API unavailability, during which some requests returned 503 Service Unavailable. Multiple API instances temporarily became unresponsive at the same time, leaving insufficient capacity to serve requests.
Service has been restored and remains stable. We are monitoring closely and investigating what caused the instances to become unresponsive.
Investigating
We are investigating an increase in 503 Service Unavailable responses.