Delayed sending to Microsoft 365 addresses
Resolved·Degraded performance

Everything has remained stable and we're not seeing any more delays since our change. We're marking the issue as resolved.

Mon, Dec 1, 2025, 01:53 PM
(1 week ago)
·
Affected components
Updates

Resolved

Everything has remained stable and we're not seeing any more delays since our change. We're marking the issue as resolved.

Mon, Dec 1, 2025, 01:53 PM

Monitoring

We have implemented improvements for delivering mail to Microsoft 365-hosted addresses and are monitoring the situation.

Mon, Dec 1, 2025, 11:54 AM(1 hour earlier)

Identified

We have identified that this issue with delayed sending affects emails to Microsoft 365 addresses only.

Our team is working on resolving this issue.

Mon, Dec 1, 2025, 10:57 AM(56 minutes earlier)

Investigating

We are currently investigating an issue with delayed sending for a very small subset of emails. Most outbound traffic is not affected in our first assessment.

Mon, Dec 1, 2025, 10:52 AM