All emails have been sent out successfully again and are no longer seeing any issues. We are going to work on improving resilience against upstream provider issues related to object storage and will share updates on this in the future.
Resolved
All emails have been sent out successfully again and are no longer seeing any issues. We are going to work on improving resilience against upstream provider issues related to object storage and will share updates on this in the future.
Monitoring
The incident with our upstream provider has been resolved. Newly submitted emails will be processed instantly and we are working on retrying those that are being held in queue.
Identified
We have identified an issue with our upstream provider causing time-outs when writing mails to storage, causing delays in sending. We will keep you updated while we are working on resolving this incident.