Intermittent delayed sending of emails
Resolved·Degraded performance

All queued emails have been processed and delivery is back to normal.

We are implementing additional failover mechanisms to mitigate future upstream incidents.

If you experience further issues, please contact support.

Mon, Jan 5, 2026, 04:37 PM
(2 weeks ago)
·
Affected components
Updates

Resolved

All queued emails have been processed and delivery is back to normal.

We are implementing additional failover mechanisms to mitigate future upstream incidents.

If you experience further issues, please contact support.

Mon, Jan 5, 2026, 04:37 PM

Monitoring

We are seeing improvements and the issue is marked as resolved with our cloud provider.

Currently, the backlog of queued emails is being processed and everything should be sent out as soon as possible.

Mon, Jan 5, 2026, 04:33 PM

Identified

The incident at our cloud provider is still ongoing.

In the meantime, we are working hard on mitigating impact and will keep you posted. Emails that are marked as queued will be sent out as soon as possible and we want to reassure you that no data is lost.

Mon, Jan 5, 2026, 04:13 PM(19 minutes earlier)

Identified

We have identified an issue with our upstream provider causing time-outs when writing mails to storage, causing delays in sending. We will keep you updated while we are working on resolving this incident.

Mon, Jan 5, 2026, 03:33 PM(40 minutes earlier)