Write-up published
Resolved
The issue has been resolved and all queued emails are sent out.
We sincerely apologies for the inconvenience and will provide a write-up later today.
If you still notice any issues, do not hesitate to contact us.
Identified
The root cause of the issue has been identified and a fix is being rolled out.
Investigating
We are seeing issues with emails being stuck in the queue and are currently investigating this incident.