We see improvements and no more bounces related to the block.
After further investigation, iCloud was having issues where it was incorrectly rejecting mail with IP block responses while it was not the case. This has been confirmed with others.
We will keep monitoring the situation closely.
No components marked as affected
Resolved
We see improvements and no more bounces related to the block.
After further investigation, iCloud was having issues where it was incorrectly rejecting mail with IP block responses while it was not the case. This has been confirmed with others.
We will keep monitoring the situation closely.
Investigating
We've been notified of intermittent delivery failures due to hard bounces to iCloud, affecting email delivery for some customers. The team is currently investigating the cause and working on resolving this issue.
If you have seen a hard bounce because of this you can safely reactivate the recipient from your suppression management.