All messages submitted during the maintenance window have been processed successfully and services are restored. Migration is now complete.
We will be monitoring closely. In case of any issues, please reach out to support.
A post-mortem on the maintenance will be published soon.
Happy easter!
Complete
All messages submitted during the maintenance window have been processed successfully and services are restored. Migration is now complete.
We will be monitoring closely. In case of any issues, please reach out to support.
A post-mortem on the maintenance will be published soon.
Happy easter!
In progress
The backlog of emails submitted during the maintenance window is being processed. The API and dashboard are available again.
Maintenance has been completed and our team is currently performing final checks to verify everything is holding up.
We will be monitoring extensively in the coming hours and days to jump in in case of any issues.
If you are seeing issues - do not hesitate to reach out to support.
In progress
There's been an issue causing a delay in restoration of the platform regarding the DNS records of our API. Due to a hiccup, these temporarily disappeared and this result might be cached for some.
We are working hard on restoring services as soon as possible.
In progress
DNS is being propagated and newly submitted emails should be processed immediately. If you still see maintenance mode, this means your DNS is still pointing to our previous infrastructure.
The backlog of emails will be processed any minute.
In progress
Maintenance is still in progress and after a successful migration of the database are verifying it's integrity.
We will keep you posted once sending will be resumed.
In progress
The API and dashboard have been put in read-only mode as we proceed to the next steps of the migration. Message submissions will be stored and processed with a delay.
In progress
Maintenance has started
Scheduled
We will be conducting maintenance on our infrastructure, migrating to our new cluster in Amsterdam, The Netherlands, with our new cloud provider. This is done to improve reliability and performance. The maintenance window is scheduled for April 3rd between 22:00 and 02:00 CEST.
During this window, the platform will be in read-only mode and, while we still accept email submissions, actual delivery will be delayed while we complete the data migration. The interruption is expected to last around 30 minutes, though some users may experience slightly longer delays depending on DNS cache propagation.
All services will automatically resume once the migration is complete, and the overall impact is expected to be minimal.