Resolved
We are no longer seeing any connection issues. A post-mortem will be shared as soon as possible.
Our findings have been shared with the developer of the package and will cooperate to fix the issue for the ecosystem.
Monitoring
Fix has been deployed for the intermittent connection errors affecting SMTP submissions with larger attachments. We are now observing traffic to confirm the issue is fully resolved. No action is required from customers.
Investigating
We are noticing degraded performance with sending larger attachment to our SMTP relay and are currently investigating the issue.