Experiencing an issue that is not shown here? Please contact our support team. Account-specific sending or deliverability issues may not be displayed on this page.
Complete
The database maintenance has been completed successfully.
Latency has returned to normal, and all services are operating normally. No further impact is expected.
In progress
The database maintenance is progressing as planned, but is taking longer to complete than initially estimated.
The platform remains stable, with increased latency still possible while the work continues. We are monitoring all services closely and will provide another update once the maintenance has been completed.
In progress
The scheduled database maintenance is now in progress.
Customers may experience increased latency while the work is being completed. We do not expect any downtime and are monitoring the platform closely throughout the maintenance.
Scheduled
We will perform a database storage upgrade on Sunday, July 19, between 21:00 and 22:00 CEST.
Customers may experience increased latency during this window. We do not expect any downtime and have safeguards in place to minimise customer impact.
We will monitor the platform closely and provide updates when the maintenance begins and once it has been completed.